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Abstract
During the last 2 decades, the technological development of computers (hardware and
software), has given the opportunity of a new approach at spatial information manage. The
Geographical Information Systems (GIS) belong to the information systems that manage the
models of geography data. With this application it is possible the digitalization and add of the
data of drills in an area. This data can be analyzed for inference of crucial conclusions about
drills condition and underwater quality and level. This can be done by printing maps and data
tables and by exporting the data for further analysis. Application’s coordinate system is the
Greek National Geodetic system (E.G.S.A. 1987) and it was made with programming
language “Avenue” of the ESRI ArcView 3.2. The application was made in such a way to be
user friendly, to cover probable future requirements and to predict – avert possible errors or
skips of the users.
Introduction
Through the last years in our country, the high climate changes and the non-rational use of
the water resources, lead to a gradual decrease in water resources. The development of
agricultural technology accompanied by indiscriminate use of water resources, which in
combination with the low efficiency of irrigation systems have caused problems related to
water quantities. Furthermore, the indiscriminate use of fertilizers and pesticides has caused
accumulation of nitrites, nitrates and other substances that pollute ground and surface water at
some areas.
In Greece, agriculture is the most important expander of water, (agricultural use of water
in Greece 86,3%, urban 10,7%, industrial 1,6% and energy 1,5%) [1] due to the increase of
irrigated areas and the use of dynamic crops with increasing demands for water. The
agricultural use, depending on the prevailing per year hydrological conditions, is close to 8387% of the resources of surface and groundwater of the country, and the use of water supply
for towns is approximately 10-12%. In our country there are already enough irrigation
systems that take water from drills. The biggest of these is in the plain of Thessaly. There are
about 198.000 drills in Greece [2].
In many parts of Greece, the needs of irrigation from surface water are not feasible,
because the peak demand coincides with the dry period, in which the supplies of surface water
are limited. This led to cover part or all of the irrigation needs by the underground waters. The
rapid increase of water needs without a sustainable management of water resources has
resulted in the deterioration of the water potential in many areas.
The overuse of ground water has caused serious effects in quality and quantity of ground
water. The change of quantitative data manifested by the dramatic fall in the underground
water levels, and is caused entirely by over pumping. The sequences are different from region
to region, depending on the structure of aquifers and the ways of refilling them.
Underground water is an important part of water resources. They function as a reservoir
from which can water of good quality can be pumped and be used for drinking as well as for
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other uses. The quantitative and qualitative degradation of ground water, that also affects the
aquatic and terrestrial ecosystems which directly or indirectly depend on them, is very
difficult to recover and it needs a lot of time and money. It is vital to prevent pollution and
depletion, so their use should be done within appropriate management plans. These plans
should be supported by tools such as databases that will be updated regularly to help us check
and manage the quality and the quantity of ground waters [3],[4],[5].
Materials and Methods
The development of the application become at four stages: a) definition of aims, b)
definition of the functions, c) planning of the application structure and d) implementation of
application.
Definition of aims become with thorough analysis of crucial issues such as: information
that would be available, data input system, search capabilities, way of view of available
information, easy use of application, and probable future requirements and uses of this
application. Definition of the functions was the result of these aims. This application makes
feasible the digitalization of all drills in a country, but for the needs of this paper, data from
the Lesvos Island was used. Application’s coordinate system is the Greek National Geodetic
system (E.G.S.A. 1987) which is the most recent coordinate system in Greece. The
application supports the usage of satellite images and orthophoto images in order to achieve
higher quality visual images of the lands. Satellite images, have the names of the satellite that
were taken (e.g. IKONOS, Spot, Landsat TM, etc). Depending on the satellite, each image has
different specifications (number of bands, spatial resolution, etc.). Orthophoto images
dimensions are 4km*3km and the total area of each one of them is 12km2. For this example
we used Landsat TM satellite image of Lesvos Island (Figure 1).

Figure 1. Landsat TM satellite image of Lesvos Island

As long as the function of the application has been determined, the next level of its
development was the planning of the structure in order that the final form would be the
expedient result. The aim of this level was the definition and the creation of the tables –
thematic background (Drills, Water points, Lesvos Unities and Database Table) as well as the
definition of these relations. There are 3 basic layers. These are: “Drills”, “Water points“ and
“Lesvos Unities” and their format are (.shp) which is a digital vector storage format for
storing geometric location and associated attribute information. Drills and water points are
represented as faucets, while Lesvos Unities are represented as closed loop, double-digitized
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polygons. All (.shp) attributes are held in a dBASE® format file. Each attribute record has a
one-to-one relationship with the associated shape record [6]. There is also a database table in
a dBASE® format file, and its purpose is to store and maintain all the data which are recorded
in the application to make possible the retrieve of drills data changes through time.
Unities are called the areas which are defined by the Topographic Service of Greece and
which are determined by natural and technical borders and have as a title the geographical
coordinates of their metacenter.
The application has 50 scripts and about 6000 lines of code, and it was made in such a
way to be user friendly, to accomplish all future needs and to support all kinds of GIS data. It
was made with programming language “Avenue” of the ESRI ArcView 3.2. The election of
ArcView 3.2 was due to its compatibility with all the versions of Microsoft Windows (Win95
to Windows Vista) and in virtue of the umpteen capabilities and the flexibility of the
programming language “Avenue”. All application data are compatible with any GIS or
database program (e.g. ArcMap, Microsoft Access etc).
Results and Discussion
The use of application is very simple and no previous experience in GIS applications is
required. The main screen of the application is shown in Figure 2.

Figure 2. Main screen of application

“Drills” and “Water Points” layers, helps user to separate the drills that haven’t got any
data added (“Water Points” layer) from the drills that have data added (“Drills” layer).
In order to draw a water point by way of its coordinates that taken from GPS, user must
selects from the application menu Draw ⇒ Water point drawing from coordinates. Then the
window of figure 3 will appear in which user has to add the coordinates of the water point that
he wants to be drawn.
If user select Cancel, the drawing of the water point will be aborted, and if he select
Draw, the drawing of water point will be done in the chosen by coordinates place, and the
application will zoom in that place.
To draw a water point from a map, or an orthophoto or a satellite image, user must select
from the application menu Draw ⇒ Start Drawing.
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After this with the draw button, the user can draw water points by clicking the left mouse
button at the desired place. If through drawing procedure a mistake is made, the user can undo
his drawing by selecting Draw ⇒ Undo Drawing.
To save the new drawn water points, user must select form application menu Draw ⇒
Save Drawing.
The next step after drawing is adding of data of the drawn water points. To do this, the
user must select with the selection tool the water point in which he wants to add data, and
select from the application menu Add data ⇒ Add data in a new drill.
Then the window of figure 4 will appear in which the user can add the information of the
new drill.

Figure 3. Water point drawing from coordinates

Figure 4. Adding data window

Some of these fields values are calculated automatically. These are:
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Mg/Ca<0,7 then the water is chalky, if 0,7<Mg/Ca<0,9 the water is dolomitic and if
Mg/Ca>0,9 the water is silicates), Source of water (if Na/K<10 then the water is rainwater,
and if 46<Na/K<48 then the water is seawater), Hardness of water (if the total water hardness
(German points) is less than 8 then the water is soft, if it has a value between 8 and 12 it is
hard mediocre, if it has a value of between 12 and 30 it is hard and if it has a value more than
30 then it is very hard).
By clicking Save the new data are saved in the table of “Drills” layer, and to the database
table of the application, in which every change of layers data is recorded. The water point,
whose data is recorded, is moving from “Water Points” layer to “Drills” layer.
Through the adding data procedure there is a mechanism that prevents the addition of
wrong values in the fields. If the user types wrong dates, incorrect values in the fields of water
chemical analysis, etc, then the application displays the corresponding error message. For
example, if the user types in the field «drill’s construction date» wrong date then will be
shown the error message of figure 5.
The application supports the modification of data (new technical features, new water
chemical analysis, change of the owner etc). To do this the user must select the drill that a
modification will be made and select from the application’s menu the command Add data ⇒
Add new data of an existing drill.
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The entry of new data of an existing drill is made with the same way as with adding new
data in a water point, and there is the same mechanism for detection of wrong values in the
fields.
The differences are:
a) The modification of drill number is not possible,
b) By clicking button Save the data of drill in layer “Drills” is modified, and a new
data entry is created in the database table of the application. In this way, the “Drills” layer
keeps the latest info from all drills, and the database table keeps up all the modifications of
drills data, so it keeps the history of all drills values.
By selecting View ⇒ View of average data values of drills (Figure 6) user can see
information and the average values of all drawn drills.

Figure 5. Error message

Figure 6. Informations and the average values of
all drawn drills window

In view menu there are some other commands. These are:
¾ View of average data values of selected drills (user can see information and the
average values of the selected drills).
¾ View of average data values of all drills from database table (user can see
information and the average values of all the data that have been recorded,
included and the modifications of the drills data).
¾ View of average data values of an drill from the database table (user can see
information, modifications and the average values of all the data that have been
recorded through time for that drill)
By selecting Print ⇒ Print data of a drill from database table it appears the window of
figure 7. From the menu of this window user can select which fields to be shown in print
preview pages.
After this selection the user can choose if he wants the data to be sorted and to choose the
way of sorting. After the sorting of the data the print preview of figure 8 will appear.

Figure 7. Selection of shown fields

Figure 8. Print preview
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In view menu there are some other commands too. These are:
¾ Print data of all drills from “Drills” layer.
¾ Print data of selected drills from “Drills” layer.
¾ Print all drills data from database table
All the application data can be printed to maps. There are many options, as modification
of title, scale of map, paper selection, change of symbols, add of 2 views in a map (Figure 9)
etc.

Figure 9. Map sample

All application data are compatible with all GIS, databases, and statistical programs for
further analysis.
Conclusion
The aims of the application are: easy search of data, observation of drills data changes
through time and presentation of the present condition of drills and under water through a
user-friendly GIS-based Graphical User Interface (GUI) that takes full advantage of the GIS
capabilities. User doesn’t need to have previous experience in GIS, and the application has the
capability to predict – avert possible errors or skips of the users. This application was
examined with various operative examples, which accomplished huge number of occasions
and degree of complexity and established that can be capable to operate unexceptionably.
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